Contains the information to process the refresh
.
...
spec {
delay-seconds (this.flightNumber) // a silly example, but shows you can use property values too
with-request {
if (this.flightState == 'active') {
intent {
goal {FlightStatus}
value {$expr(this.carrier)}
value {$expr(this.flightNumber)}
}
}
}
}
...
with-request required | Specify that you want a new intent upon refresh |
delay-seconds optional | Delay in seconds before sending the refresh intent |
Copyright 2025 Samsung All rights reserved